Support the ongoing development of Laravel.io →
Authentication Laravel Validation
Last updated 1 month ago.
2

I still haven't found the solution. I have tried all of the following:

I removed the "auth" middleware from the verification page
I changed the order of the routes and put the verification before the "notice".
I tried from several browsers
I analyzed the apache logs to see if they received the correct URL in the emails and they did.

Do you have any idea ? I'm losing dozens of users every day who can't verify their address... Thanks.

0

@mallaurygerard did you check what the middlewares are on your verification route? And if it didn't match any other route?

0

@tvbeek Yes, here are the middlewares :

// $this->middleware('auth'); // Disable it to allow non logged user to verify their address
$this->middleware('signed')->only('verify');
$this->middleware('throttle:6,1')->only('verify', 'resend');

I disabled the 'auth' middleware to be sure.

And I switched routes to be sure too :

Route::get('email/verify/{id}/{hash}', 'Auth\[email protected]')->name('verification.verify');
Route::get('email/verify', 'Auth\[email protected]')->name('verification.notice');
Last updated by @mallaurygerard 4 months ago.
0

Sign in to participate in this thread!

Full Stack Europe

Your banner here too?

Moderators

We'd like to thank these amazing companies for supporting us

Your logo here?

The Laravel portal for problem solving, knowledge sharing and community building.

© 2022 Laravel.io - All rights reserved.