Support the ongoing development of Laravel.io →
Testing
Last updated 3 months ago.
0

I'm really not sure but fresh install sounds like write permissions of your storage&vendor folders and a restart of your php server service may also help

(code 500 means Internal Error)

are you able to open the page by using web browser?

0

When I said a fresh install I meant a successful instal :) Yes permissions are ok. And yes I have a code 200 on the page using a browser.

0

I have the exact same error, any solutions?

0

Any errors in the log file?

0

Yes there is an error about session headers already sent but not sure why this would be:

#[2015-04-16 03:02:56] testing.ERROR: exception 'ErrorException' with message 'session_start(): Cannot send session cookie - headers already sent by (output started at ..\vendor\phpunit\phpunit\src\Util\Printer.php:139)' in ..\storage\framework\views\323c66e73905cec9897f3bb901cee8b0:77 Stack trace: #0 [internal function]: Illuminate\Foundation\Bootstrap\HandleExceptions->handleError(2, 'session_start()...', 'C:\xampp\htdocs...', 77, Array) #1 ...\storage\framework\views\323c66e73905cec9897f3bb901cee8b0(77): session_start() #2 ...\vendor\laravel\framework\src\Illuminate\View\Engines\PhpEngine.php(39): include('C:\xampp\htdocs...')

Last updated 7 years ago.
0

Ok found the problem, my home page template layout had a session_start() called and that was causing issues when trying to get the url in phpunit, removed it and it worked.

The log did show the culprit file, so looking into that helped identify this issue.

Last updated 7 years ago.
0

Sign in to participate in this thread!

Full Stack Europe

Your banner here too?

jrean jrean jrean Joined 4 Mar 2014

Moderators

We'd like to thank these amazing companies for supporting us

Your logo here?

The Laravel portal for problem solving, knowledge sharing and community building.

© 2022 Laravel.io - All rights reserved.