Support the ongoing development of Laravel.io →
Configuration
Last updated 3 months ago.
0

I am having this issue as well but in the reverse, Originally started using 4.2 and now I am trying to downgrade to 4.1.18 for compatability and I am getting this same error.

Last updated 3 months ago.
0

Had the same problem.

Solved by generating new key for the app. see http://laravel-recipes.com/recipes/283.

NOTE / WARNING: it says that by generating new keys "that passwords saved with Hash::make() will no longer be valid." But for me, the password still works, i'm just testing the framework so it might be different i guess.

Last updated 3 months ago.
0

Hash::make() doesn't use the key, only Crypt::encrypt/decrypt. And the cookies I think. Clearing the cookies usually helps, or try clearing you storage cache.

Last updated 3 months ago.
0

Hash::make() doesn't use the key, only Crypt::encrypt/decrypt. And the cookies I think. Clearing the cookies usually helps, or try clearing you storage cache. MCRYPT_RIJNDAEL_256 should be the same as in 4.1, if you don't set it, it will default to MCRYPT_RIJNDAEL_128 (the more 'approved' standard)

Last updated 3 months ago.
0

Thanks all. And like @barryvdh said, Hash::make() does not use the key so passwords continue to work.

Last updated 3 months ago.
0

mhuxain said:

Had the same problem.

Solved by generating new key for the app. see http://laravel-recipes.com/recipes/283.

NOTE / WARNING: it says that by generating new keys "that passwords saved with Hash::make() will no longer be valid." But for me, the password still works, i'm just testing the framework so it might be different i guess.

Someone needs to add this to the release notes or upgrade guide if/when it is created. :)

I upgraded from 4.1.* - Save error.

Last updated 3 months ago.
0

What if I use Crypt class in different places, and now when i try Crypt::decrypt() i get an error? I did the upgrade from version 4.1.30 to 4.2.1.

'ErrorException' with message 'mcrypt_decrypt(): The IV parameter must be as long as the blocksize' in /vendor/laravel/framework/src/Illuminate/Encryption/Encrypter.php:112

What must I do now to avoid having to encrypt the data again?

Last updated 3 months ago.
0

Same problem here. Help

Last updated 3 months ago.
0

Did you add the MCRYPT_RIJNDAEL_256 cipher to the app/config/app.php file as mentioned in the upgrade guide?

Last updated 3 months ago.
0

i did everythink like in the upgrade guide but i get still an

php artisan serve
Laravel development server started on http://localhost:8000
// AFTER first Request attemption server halt with
Segmentation fault

error. i cleaned up my base route like tat

Route::get('/', function() { });

Last updated 3 months ago.
0

Clear the browser cache and storage folder. It should work fine.

Last updated 3 months ago.
0

vivekiran said:

Clear the browser cache and storage folder. It should work fine.

nope that wasnt the problem. Dont know why but i switch to a vagrant box (Homestead) and now it works.

anyway, thanks

Last updated 3 months ago.
0

Sign in to participate in this thread!

Full Stack Europe

Your banner here too?

Moderators

We'd like to thank these amazing companies for supporting us

Your logo here?

The Laravel portal for problem solving, knowledge sharing and community building.

© 2022 Laravel.io - All rights reserved.