Support the ongoing development of →
Installation Configuration
Last updated 1 year ago.

I haven't touched the file. I have destroyed and re-upped a few times to no avail.

Last updated 1 year ago.

The problem is your file endings:

citricsquid said:

==> default: /vagrant/scripts/ line 2: $'\r': command not found

This is a line ending problem. You're using windows, I presume? You need to make sure your editor saves all files with the linux line ending, not the windows line ending. The windows line ending causes problems with Vagrant.

Last updated 1 year ago.

Thank you @citricsquid and @mvtenorio, I was able to provision the machine, I am almost there. But now I have the issue when I navigate to: it gives me a blank white screen with: No input file specified.

EDIT: Changed the Key in YAML to exclude .pub

authorize: C:/VM/Homestead/

    - C:/VM/Homestead/homestead

    - map: C:/VM/Laravel
      to: /home/vagrant/restbox

    - map:
      to: /home/vagrant/restbox/public

EDIT2: Then had to edit the sites-enabled in nginx, to get the path to the VM right, works now. Thanks for the help fellas!

Last updated 1 year ago.

And how do you change the "sites-enabled"?

I have VirtualBox, Vagrant running. Homestead is "installed" or whatever. But all I get is "No input file specified."

Last updated 1 year ago.

Sign in to participate in this thread!


Your banner here too?


We'd like to thank these amazing companies for supporting us

Your logo here?

The Laravel portal for problem solving, knowledge sharing and community building.

© 2024 - All rights reserved.