Support the ongoing development of Laravel.io →
Installation Configuration
Last updated 3 months ago.
0

It looks like you have not got the document root for you laravel application setup correctly on the web server, there is not need to change the .htaccess for this.

If you could provide a little more info on the env your running eg apache or nginx i can point you in the right direction

Last updated 5 years ago.
0

gmann1982 said:

It looks like you have not got the document root for you laravel application setup correctly on the web server, there is not need to change the .htaccess for this.

If you could provide a little more info on the env your running eg apache or nginx i can point you in the right direction

Thanks for your reply - it sounds possible that the root is wrong, though I've not done anything different other than the default, and then try some .htaccess options. The server is running Apache.

0

can you please provide the vhost for that specific app your trying to run?

0

gmann1982 said:

can you please provide the vhost for that specific app your trying to run?

I hope I've understood correctly... here's the directory of the "home" Laravel project:

/var/www/vhosts/chill-pill.com/home/

0

and in that folder you have a public folder?

You need to updated the document root for the vhost of that domain to /var/www/vhosts/chill-pill.com/home/public

0

SImply your question is how to remove public from url steps :

    1 : you have one file in your root directory named : server.php 
        rename it to index.php
    2 : you have .htaccess file in root/public directory 
        copy this file to your root directory

Notes : now wherever you use asstes you have to add public before url.
1

Sign in to participate in this thread!

Cloudways

Your banner here too?

Moderators

We'd like to thank these amazing companies for supporting us

Your logo here?

The Laravel portal for problem solving, knowledge sharing and community building.

© 2022 Laravel.io - All rights reserved.