Support the ongoing development of Laravel.io →
Configuration
Last updated 1 month ago.
0

mod_rewrite enabled?

Last updated 1 month ago.
0

As above you need to make sure you have mod_rewrite enabled on your web server.

Check out the public/.htaccess file.

Last updated 1 month ago.
0

Using windows 8 and bitnani xampp control panel v3.2.1. It worked automatically like magic. Awesome!

Last updated 1 month ago.
0

It is enabled but still nothing :(

public/.htaccess


<IfModule mod_rewrite.c>
    <IfModule mod_negotiation.c>
        Options -MultiViews
    </IfModule>

    RewriteEngine On
    RewriteBase /laravel/public/ 
    # Redirect Trailing Slashes...
    RewriteRule ^(.*)/$ /$1 [L,R=301]

    # Handle Front Controller...
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^ index.php [L]
</IfModule>

Last updated 1 month ago.
0

Anyone?

Last updated 1 month ago.
0

Check that you have "AllowOverride" specified in apache config. Something like this:

<Directory /var/www/public>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride all
    Order allow,deny
    allow from all
</Directory>

It's default "AllowOverride None" which effectively stops your .htaccess files from working.

Last updated 1 month ago.
0

Sign in to participate in this thread!

Full Stack Europe

Your banner here too?

Moderators

We'd like to thank these amazing companies for supporting us

Your logo here?

The Laravel portal for problem solving, knowledge sharing and community building.

© 2022 Laravel.io - All rights reserved.