Back

php artisan list display strange characters


Hi,

I recently installed new updates of Win 10 and after it began strange characters in output of my cmd. I type command php artisan list and there were strange characters like [32m , [39m ... and so on. So output looks like:

... [33mview[39m ...

How to solve this?

Tyna13 replied 8 months ago

I guess you already found the solution somewhere else but just in case someone comes here looking for an answer... Change the terminal options to "xterm-256 color". Right click in the terminal → options → terminal → change the type to xterm-256 color → restart terminal. http://prntscr.com/ewgwmq

That being said.. when I was looking for a solution myself I saw some people reporting this didn't work for them in win 10. Quick instant but not optimal solution could be to write --no-ansi at the end of every single command. For an actual solution check some other forums. This didn't happen to me so I can't say what actually works :(


Sign in to participate in this thread!



We'd like to thank these amazing companies for supporting us