Support the ongoing development of Laravel.io →
Installation Configuration Requests
Last updated 3 months ago.
0

Hey, you need to enable debug mode in app.php under app/config. If it's production server, you should NOT have this on, as it exposes your code to the public. For local development you should try Homestead :)

Last updated 3 months ago.
0

Yes. I enabled

After checking on server. I see that error was writen to nginx error log file : http://pastebin.com/9T3qMnnq

But why it wrote to here ? It should show on debug page of Laravel same as other error!

Last updated 3 months ago.
0

Hi all. After try many ways, i knew how to fix. In nginx vhost config. You should comment line: error_page 500 502 503 504 /50x.html; So, Laravel will process debug instead pass to Nginx log.

Last updated 3 months ago.
0

Slightly related, but I was having an issue with Homestead 2 not rendering the Laravel 4.2 debugger but instead Nginx was displaying I presume it's default 404 page. Even with appropriate debug settings per environment I could not get this working.

Finally the above advice to simply comment out the error_page 404 /index.php; in my nginx.conf file worked. Still learning Laravel so not sure why I needed to do this but thought to post it up here for anyone else.

0

Sign in to participate in this thread!

Full Stack Europe

Your banner here too?

callmehuyv callmehuyv callmehuyv Joined 16 Nov 2014

Moderators

We'd like to thank these amazing companies for supporting us

Your logo here?

The Laravel portal for problem solving, knowledge sharing and community building.

© 2022 Laravel.io - All rights reserved.