Support the ongoing development of →
posted 9 years ago
Last updated 2 years ago.

did you perform this step: composer create-project laravel/laravel your-project-name --prefer-dist from

Last updated 2 years ago.

I tried with the command: "php-cli composer create-project laravel/laravel test --prefer-dist"

at the beginning it works until some point where I get an error:

Generating autoload files Status: 500 Internal Server Error Cache-Control: no-cache

then it begin to write something that looks like the content of an HTML file

I know I probably missed something in the install but i cannot find what is the problem... Thank you so much for any kind of advice !

Last updated 2 years ago.

It seems to be an error of permission but i don't understand why... The project is not even created so there is no project folder when i invoke the command "php-cli composer create-project laravel/laravel test --prefer-dist"

How is it possible to have a permission problem in such a case ? Is there any way to solve this issue ?

Thank you very much for the help, I am really beginning to become mad at this installation thing... it worked so well in my Homestead local environment...T_T

Last updated 2 years ago.

I think I found the problem

It doesn't come from me, I think the server laravel.phar is down or something like that

When I go to the page

I get the same HTML code than when i try to run "php-cli composer create-project laravel/laravel test --prefer-dist"

Last updated 2 years ago.

Sign in to participate in this thread!


Your banner here too?

cyprienR cyprienr Joined 26 Nov 2014


We'd like to thank these amazing companies for supporting us

Your logo here?

The Laravel portal for problem solving, knowledge sharing and community building.

© 2024 - All rights reserved.