Support the ongoing development of Laravel.io →
Authentication Eloquent Architecture
Last updated 4 months ago.
0

Have you searched the http://laravel.io/forum?tags=authentication,security section, there are several posts
where folks had similar problems and were solved. Are you using L4 or L5? Have you tried models just to verify it would work there? Have you dumped your autoloads, have you tried

 use Snippet\User;

Did you check namespacing for Snippet, making it exactly like models is setup? etc etc etc.

Last updated 7 years ago.
0

Im using 4.2.* Laravel. I get my error here: /var/www/snippet/vendor/laravel/framework/src/Illuminate/Auth/EloquentUserProvider.php

         *
	 * @return \Illuminate\Database\Eloquent\Model
	 */
	public function createModel()
	{       
		$class = '\\'.ltrim($this->model, '\\');
 
		return new $class; //\Snippet\User
	}

but if i put \Snippet\User instead $class everything is fine.

Last updated 7 years ago.
0

Having the same problem right now, any updates on a solution?

UPDATE:

Have you tried to change the "model" in you auth.php config to Snippet\User ?

'model' => 'Snippet\User',
Last updated 7 years ago.
0

Can you please post the complete error?

0

Sign in to participate in this thread!

LoadForge

Your banner here too?

rasparac rasparac Joined 18 Feb 2014

Moderators

We'd like to thank these amazing companies for supporting us

Your logo here?

The Laravel portal for problem solving, knowledge sharing and community building.

© 2022 Laravel.io - All rights reserved.