Support the ongoing development of Laravel.io →
Requests
Last updated 2 weeks ago.
0

Have you set the port in your app.url configuration?

Last updated 2 weeks ago.
0

You're talking about the url setting in config/app.php? If so, why would that matter? It's description states that this is for running php artisan tasks.

Last updated 2 weeks ago.
0

Updated title, but left original post alone. It isn't just Redirect::to() that is being problematic. It seems that anything Laravel is doing, such as {{{ asset(...) }}} is ignoring the port.

Last updated 2 weeks ago.
0

I tracked it down and it looks like it's an issue with Codio's new virtual machines. Symfony expects HTTP_HOST to contain any non standard ports, which makes sense, but they aren't setting it.

Last updated 2 weeks ago.
0

Sign in to participate in this thread!

Cloudways

Your banner here too?

nesl247 nesl247 nesl247 Joined 6 Feb 2014

Moderators

We'd like to thank these amazing companies for supporting us

Your logo here?

The Laravel portal for problem solving, knowledge sharing and community building.

© 2022 Laravel.io - All rights reserved.