Support the ongoing development of →
posted 9 years ago
Last updated 1 year ago.

Are you sure that $conn is an object? I would check that first ;) As far as I can tell, it is not an error message on the session facade not working.


Yes it is an object. I tried hard coding an input as follows; Session::put('key','value'); It still generated the same error. Also an echo would print out the $conn->resourceId


Hmm, would you mind trying the following two things:

/Session::put('key',$conn->resourceId); // note the slash in front of 'Sessions'

and with the helper method

session(['key' => $conn->resourceId]);

If either one works, you most likely do not have the correct namespaces. In that case please read this


Sign in to participate in this thread!


Your banner here too?

Anoukh anoukh Joined 4 Mar 2015


We'd like to thank these amazing companies for supporting us

Your logo here?

The Laravel portal for problem solving, knowledge sharing and community building.

© 2024 - All rights reserved.