Support the ongoing development of Laravel.io →
Configuration
Last updated 6 months ago.
0

Have you ensured that your storage folder and all its subfolders are writeable? This could be a permissions problem writing the log entry for the http no found exception when your route fails.

Last updated 6 months ago.
0

For testing I set storage (and all subfolders+files) to chmod 777. Still same Problem :-(

Last updated 6 months ago.
0

php version?

Last updated 6 months ago.
0

it´s version 5.5

Refered to this https://stackoverflow.com/questions/17228936/laravel-default-h...

I added a slash to last line: RewriteRule ^ /index.php [L]

It fixed the internal Server Errors but not the redirect Loop

Last updated 6 months ago.
0

Try adding this before the rewrite rules.

RewriteBase /

I have found this to be necessary on some hosts.

Last updated 6 months ago.
0

@spekkionu I´ve added the line - still getting a redirect Loop when typing a url to a folder (e.g. mydomain/images)

<IfModule mod_rewrite.c>
    <IfModule mod_negotiation.c>
        Options -MultiViews
    </IfModule>

    RewriteEngine On
    RewriteBase /

    # Redirect Trailing Slashes...
    RewriteRule ^(.*)/$ /$1 [L,R=301]

    # Handle Front Controller...
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^ /index.php [L]
</IfModule>
Last updated 6 months ago.
0

Sign in to participate in this thread!

Full Stack Europe

Your banner here too?

Moderators

We'd like to thank these amazing companies for supporting us

Your logo here?

Laravel.io

The Laravel portal for problem solving, knowledge sharing and community building.

© 2022 Laravel.io - All rights reserved.