Support the ongoing development of Laravel.io →
Configuration Mail Queues
Last updated 8 months ago.
0

You can use a queue to send the email so your main app doesnt slow down.

Last updated 8 months ago.
0

Thank you for your response. I am just sending 1 email as a test and yet still exceeding on the 60 second timeout. Any idea what is the problem? And can you explain how mail server works?

Last updated 8 months ago.
0

I use gmail all the time, mails are usually sent within 5 seconds. What do you have as a host? gmail.com will not work and will result in a timeout, use smtp.gmail.com instead

For future reference: include some code samples for a question like this, otherwise we just have to guess - makes it harder for everybody :-)

Last updated 8 months ago.
0

sorry about that elimentz :)

please refer to this link for my simple test

http://laravel.io/bin/Pd4Xv

Last updated 8 months ago.
0

Daskul, have you tried to use the following port number?

//app/config/mail.php file
'port' => 587 //default port number

In my configuration this port number help me to send mails using gmail.

Hope it helps you.

Last updated 8 months ago.
0

codeATbusiness said:

Daskul, have you tried to use the following port number?

//app/config/mail.php file 'port' => 587 //default port number

In my configuration this port number help me to send mails using gmail.

Hope it helps you.

yes i tried it but no luck. still having timeout.

I am under a domain. what are the things I need to check here?

Last updated 8 months ago.
0

for gmail, encryption has to be 'ssl' rather than 'tls'. hope that helps!

Last updated 8 months ago.
0

sdsadas asdasdasdasdsd

Last updated 8 months ago.
0

@Daskul You setting are correct must be your internet connection or your host server is having some down time, was having the same issue, i just changed my port and enc type to what you are using an changed my email and it works perfectly!

Last updated 8 months ago.
0

Did you find any solution @Daskul??

Im using a shared hosting in Godaddy and Google as mail server.

I've tested these 3 ("smtp", "mail", "sendmail") and the result is the same: I got the mail in my inbox with a 3min delay even thought the mail has the time as sent 3min ago.

Im starting to think the delay is coming from the framework. And im using the option send. (by the way)

Thanks!

0

Sign in to participate in this thread!

LoadForge

Your banner here too?

Daskul daskul Joined 22 Mar 2014

Moderators

We'd like to thank these amazing companies for supporting us

Your logo here?

Laravel.io

The Laravel portal for problem solving, knowledge sharing and community building.

© 2023 Laravel.io - All rights reserved.