Support the ongoing development of →
posted 9 years ago
Last updated 2 years ago.

Just tried this (added \Log::debug('test')) to boot method of RouteServiceProvider and it works.

Maybe your debug is turned off? Try replacing logging with dd($router) or some other kind of termination.


That does not work either. Like I told, I can even delete the whole content of the RouteServiceProvider file and I don't get any errors. Can't figure this out...

Last updated 9 years ago.

Probably you have optimized the framework previously. In this case, laravel creates a single file from all necessary framework files to load faster. So, when a request is made, this file will be read instead of many separate files. You need to remove the optimized file:

$ php artisan clear-compiled


Thank you so much the clear-compiled command solved the problem!

Last updated 9 years ago.

Sign in to participate in this thread!


Your banner here too?

MightyM mightym Joined 25 Apr 2015


We'd like to thank these amazing companies for supporting us

Your logo here?

The Laravel portal for problem solving, knowledge sharing and community building.

© 2024 - All rights reserved.