Support the ongoing development of →
Installation Configuration
Last updated 2 years ago.

I had some similar experience sometimes. Switching to PHP FastCGI (php-fpm) solved it.


I used php5-fpm on the nginx setup, didn't notice a difference, could be a php config issue tho


Is the mysql (I'm assuming that's the database in use) running on socket or tcp?

EDIT: Also, if all else fails, maybe try something like to see what method is taking too long or if it's a general php slowness.

Last updated 8 years ago.

If you have PHP slowness turning on Zend Opcache might help, I doubt this will fix the "real" problem but it's worth trying. You must be on PHP 5.5 or newer tho.

  1. Installation steps and recommended settings can be found here
  2. Don't forget to set "opcache.enable = 1" in your php.ini and you might probably want to restart php-fpm at this time.
  3. Install a web based monitor to verify that caching is up and running, I personally use this one
  4. Tweak the opcache settings in your php.ini, test performance, rinse and repeat

thanks guys, found the offending code, it was an inefficient nested eloquent query.

I think in dev there was less data so I got away with it - in production there was more data so it became much slower


Sign in to participate in this thread!


Your banner here too?

RexT4 rext4 Joined 2 Apr 2015


We'd like to thank these amazing companies for supporting us

Your logo here?

The Laravel portal for problem solving, knowledge sharing and community building.

© 2024 - All rights reserved.