Support the ongoing development of Laravel.io →
Installation Laravel
Last updated 2 weeks ago.
0

Make sure your local php version is 7.3. I am not sure if a dev dependency dictates the lowest supported php version.

0
moderator Solution

I suspect you have created the project or did an composer update on a system with PHP 7.3

Laravel 6 requires mockery/mockery ^1.0 (See: https://github.com/laravel/laravel/blob/6.x/composer.json#L19 )

The most easy way is by removing your composer.lock and do a new install (that is in fact the same as update because of the missing composer.lock)

1

composer.lock was the issue. I had done a composer install in php 7.3 environment earlier. Sorry for the inconvenience. But I do have one question. Its regarding semantic versioning, rather than Laravel. What makes ^1.0 install 1.3 and not 1.4? Coz I have seen that there is a 1.4 version of mockery. I guess, I should be asking this in some other forum. I'm just throwing it out there. Maybe it has something to do with the following.

"minimum-stability": "dev", "prefer-stable": true,

Last updated 1 year ago.
0

With ^1.0 makes composer install the latest 1.* version that is possible. But because 1.4 requires PHP 7.3 composer will not install that version on PHP 7.2 And then you get version 1.3 because that is the latest version that is possible for you.

1

Sign in to participate in this thread!

Full Stack Europe

Your banner here too?

nazan nazan nazan Joined 16 Sep 2014

Moderators

We'd like to thank these amazing companies for supporting us

Your logo here?

The Laravel portal for problem solving, knowledge sharing and community building.

© 2022 Laravel.io - All rights reserved.