Support the ongoing development of Laravel.io →
Installation Configuration
Last updated 2 weeks ago.
0

Actually, Laravel requires PHP >= 5.3.7. I deployed a Laravel app on a host with PHP 5.3.28 and it works just fine.

Last updated 2 weeks ago.
0

Should really be going with hosting that at the very least has 5.4 support; we set up vps for our client projects so we have absolute control over the environment and for clients that host themselves we explain why 5.3 is a problem and why they should update to 5.5 and for the most part it is a non-issue as they are throwing enough money at projects to want the best.

Another word of caution would be to note that quite a few packages are beginning to drop 5.3 support; so it should really be time to migrate your PHP version if you haven't already.

Last updated 2 weeks ago.
0

I agree that 5.4 is a sensible minimum but it's not always feasible in a corporate environment. Development doesn't always control their environment.

Last updated 2 weeks ago.
0

If you want to 5.3 then use Laravel 4.0

Last updated 2 weeks ago.
0

If you want to be able to keep the Laravel app up to date, don't use 5.3 anymore.

Last updated 2 weeks ago.
0

5.3 is in its end of life cycle. It will stop receiving security updates mid way through this year.

Last updated 2 weeks ago.
0

No doubt that 5.5 is highly preferable, but stating that Laravel does not support 5.3 and one must avoid Laravel if one can't go at least 5.4 (that's practically what the OP said) is just too extreme imho.

PS: if Laravel >= 4.1 doesn't support 5.3 any longer, then the docs must be changed.

Last updated 2 weeks ago.
0

mrberggg said:

I agree that 5.4 is a sensible minimum but it's not always feasible in a corporate environment. Development doesn't always control their environment.

Unfortunately this is quite often true from what I have heard.

Last updated 2 weeks ago.
0

popolla said:

No doubt that 5.5 is highly preferable, but stating that Laravel does not support 5.3 and one must avoid Laravel if one can't go at least 5.4 (that's practically what the OP said) is just too extreme imho.

PS: if Laravel >= 4.1 doesn't support 5.3 any longer, then the docs must be changed.

Laravel 4.2 is going up to 5.4 minimum. So things will be updated as-needed when that goes stable.

Last updated 2 weeks ago.
0

Sign in to participate in this thread!

LoadForge

Your banner here too?

Moderators

We'd like to thank these amazing companies for supporting us

Your logo here?

The Laravel portal for problem solving, knowledge sharing and community building.

© 2022 Laravel.io - All rights reserved.